2 NVMe drev - giver det problemer?

HDD/SSD d.  28. december. 2018, skrevet af Burgurne
Vist: 624 gange.

Burgurne
 
Nyhedsskribent
Tilføjet:
28-12-2018 17:03:20
Svar/Indlæg:
4319/847

Hej.

I dag har jeg system og nogle spil på 960EVO 500Gbyte NVMe drev, men det er nu blevet for småt, så jeg har købt (men endnu ikke modtaget) Samsung 970EVO 500Gbyte NVMe. Min plan er så vha Acronis at flytte systemdisken over på 970EVO, da dette drev burde være lidt hurtigere end 960EVO (jaja, jeg ved godt, jeg ikke vil kunne mærke forskel). Men når overflytningen så er fuldført, hvordan så med BOOT? I BIOS kalder den det jo "Windows Manager" (eller noget lign.), og hvordan kan jeg så bestemme, at det er fra 970EVO den skal boote, så jeg kan få slettet 960EVO helt og lavet det om til systemdrev?

Hvordan klarer et bundkort som mit sig med 2 NVMe drev? ASUS ROG Z370-H. Hvordan fordeler det PCI-lanes, når begge drev er i brug som NVMe, så den ikke tager lanes fra SATA? Disse lanes må vel så tages et andet sted fra, men hvor? Det skrives der ikke noget om i manualen.

Vil det være en fordel at bruge en PCIe adapter til det ene NVMe drev, så det er PCIe lanes der bruges i stedet for ??? lanes? Så vil mit grafikkort godt nok kun have 8 lanes til rådighed, men så ved jeg da i det mindste hvor de lanes er taget fra.

Nogen herinde med erfaring med 2 NVMe drev i en PC med Z370 chipsæt?

KleitusIV
 
Nyhedsskribent
Tilføjet:
28-12-2018 18:17:48
Svar/Indlæg:
3615/260

Ift det praktiske i at overføre med Acronis, så gør som du har planlagt (sæt begge i og overfør det hele) og boot computeren KUN med den nye 970EVO og check at alt virker som det skal. Derefter kan du boote KUN med din gamle 960EVO i maskinen fra en Windows USB installation. Gå igennem install menuen og slet alle partitioner på din 960 EVO og sluk maskinen. Herefter kan du boote med din nye 970EVO sammen med din gamle 960EVO og du kan nu oprette en ny partition på din 960EVO inde fra Windows.

 

Ift PCIe lanes skulle Z370 have 24 lanes, så hvis der gives 2x4 til dine M.2 drev er der stadig 16 til grafikkortet, så burde ikke være noget problem.



alenkaer
 
Enthusiast
Tilføjet:
28-12-2018 21:06:36
Svar/Indlæg:
238/6

Har Asus Z370-G, hvis jeg kører 2 NVMe drev ender det en med kun at køre PCIe 3.0x2. Skulle bare prøve at sætte dem raid



Burgurne
 
Nyhedsskribent
Tilføjet:
28-12-2018 22:02:55
Svar/Indlæg:
4319/847

#2 Okay, så skal måske alligevel bruge min gamle PCIe adapter? På den måde får de i hvert fald begge 4 lanes til rådighed. 

#1 Ja, det lyder faktisk som en god ide at gøre sådan. Tak for info 🙂



freak_master
 
Redaktør
Tilføjet:
29-12-2018 00:11:57
Svar/Indlæg:
5803/461

Dine M.2 porte kører begge igennem chipsettet. Din CPU har kun 16 PCIe baner, men det er dit chipset der tilbyder de 24. Problemet er bare DMI 3.0 der ikke har en større båndbredde end 3.5GB/s, hvilket betyder at du altså ikke bare kan smække så meget til som du vil, og se det hele kører på fuld skrue. Chipsettet styrer både SATA, USB, netværk og andre PCIe udvidelseskort. Så har du 2x M.2 diske til, kan du ikke forvente fuld hammer på begge på samme tid. Det samme gælder en SATA SSD, eller hvis du bruger en USB pen kan dette også sænke dine NVMe diske.

 

Hvis du ikke vil køre RAID, og blot skal se begge diske i Windows kan du med fordel nappe 8 PCIe 3.0 baner fra dit grafikkort, men hvis du blot kører x4 på NVMe disken ender du altså med ikke at bruge 4 baner der kunne have været brugt, men din disk skal sidde i PCIe x16 nummer to, ellers har den ikke direkte forbindelse til CPU'en.



Burgurne
 
Nyhedsskribent
Tilføjet:
29-12-2018 00:55:11
Svar/Indlæg:
4319/847

Jeg skal ikke køre raid med dem, så bare de en ad gangen har adgang til 4 lanes er det godt nok. Jeg kan ikke se ud fra manualen, hvilke lanes de 2 NVMe porte har/bruger på bundkortet, så jeg ved stadig ikke om det er OK bare at sætte en i hver, eller om den ene så må nøjes med 2 lanes. Ud af de 24 lanes til chipsættet går der jo en del til SATA mv., så måske er der ikke 2*4 til rådighed gennem chipsættet?

Jeg ved selvfølgelig meget mere når jeg engang har fået den så jeg kan teste selv. Både hver for sig, og samtidig 😉. Den skulle være afsendt fra ProShop 28/12, men hvor længe PostNord er om at finde en pakkeboks her omkring nytår, det tør jeg ikke gætte på. 🤡

 

EDIT: Jeg har fundet dette billede af lanes i et Aorus Z370, men det må vel være det samme på et ASUS Z370?




Svaret blev redigeret 1 gang, sidst af Burgurne d. 29-12-2018 01:38:51.


freak_master
 
Redaktør
Tilføjet:
29-12-2018 02:03:49
Svar/Indlæg:
5803/461

Jeg tror at det billede du har fundet beskriver det meget godt. Om dit ASUS bundkort har 2 ASMedia USB 3.1 skal jeg ikke kunne sige. Men dit bundkort har jo kun 2 M.2 pladser, og ikke 3 som der er i det billede du har fundet.

Hvis man kigger på specifikationerne:

https://www.asus.com/dk/Mother...

Så bemærker jeg disse linjer:

1 x M.2 Socket 3, with M key, type 2242/2260/2280/22110 storage devices support (SATA & PCIE 3.0 x 4 mode)*1
1 x M.2 Socket 3, with M key, type 2242/2260/2280 storage devices support (PCIE 3.0 x 4 mode)

For mig ser det ud til at den øverste M.2 port vil være den nederste M.2 port i dit billede, og den nederste M.2 port vil være M.2 porten i midten i dit billede.

Det betyder at du kan vælge to ting. Enten kan du smide begge diske i de to M.2 porte og undvære SATA6G_1 og SATA6G_2.

Du kan også smide SSD'en i din PCIe adapter. For at få SSD'en til ikke at tage båndbredde fra dit grafikkort skal du vælge den nederste PCIe x16 port, men se lige disse linjer i specifikationerne:

2 x PCIe 3.0/2.0 x16 (x16 eller to x8) 
1 x PCIe 3.0/2.0 x16 (x2-tilstand) 
3 x PCIe 3.0/2.0 x1 

For mig at se så kører den sidste PCIe x16 port kun x2, hvilket selvfølgelig vil hæmme din SSD ret meget.

Sidste løsning er at smide din PCIe adapter i PCIe x16 porten i midten. Så vil dit grafikkort køre med x8, og begge dine SSD'er x4. Det betyder så også bare at du har 4 PCIe baner fra din CPU som du ikke bruger.

Hvis du smider begge SSD'er i M.2 portene vil de begge køre x4.

Havde jeg været dig ville jeg sætte dem begge i M.2 portene og kalde det for en dag. Det er nemmere at arbejde med, det ser pænere ud, og ikke mindst skal du kun opgive 2 SATA porte, istedet for de andre muligheder, som jeg ærligt synes bliver noget rod. Især hvis du ikke bruger de SATA porte alligevel, så er det absolut en no-brainer. Du bruger jo ikke begge SSD'er på en gang ved fuld skrue. Det skulle da lige være imens du cloner disken, men så lang tid tager det vist heller ikke og skal jo kun gøres en enkelt gang.

Jeg vil lige understrege at når jeg skriver den "øverste" M.2 port så mener jeg den øverste i listen af specifikationer, på selve bundkortet kan jeg se at det jeg kalder den "øverste" M.2 port faktisk er den nederste der sidder lige under chipset køleren.



Toronto
 
Superbruger
Tilføjet:
29-12-2018 02:37:24
Svar/Indlæg:
128/1

Nu kan jeg lige pludselig huske, hvorfor det var, at jeg købte almindelige SSDére!

Det var dog en voldsom forklaring, tak for din ulejlighed freak_marster, med at pensle det ud, det satte nogle ting på plads for mig



freak_master
 
Redaktør
Tilføjet:
29-12-2018 12:03:41
Svar/Indlæg:
5803/461

Det var så lidt 🙂



Burgurne
 
Nyhedsskribent
Tilføjet:
29-12-2018 13:30:07
Svar/Indlæg:
4319/847

Hmmm, jeg venter stadig på mit drev. Proshop siger de har afsendt det, og de har trukket pengene, men Postnord mener ikke de har modtaget pakken fra Proshop endnu. Det må være et meget langsomt bud der fragter pakken fra proshop til postnords pakkeindlevering ... foreløbig har det varet 2 dage. Jeg vender tilbage når/hvis drevet når hjem til mig.



alenkaer
 
Enthusiast
Tilføjet:
29-12-2018 13:41:09
Svar/Indlæg:
238/6

Måske det mit lydkort, der deler lanes med M.2_2 porten. Så det kunne måske være man lige skulle prøve at hive det ud :)



freak_master
 
Redaktør
Tilføjet:
29-12-2018 14:58:22
Svar/Indlæg:
5803/461

#9

Bare fint 🙂

 

#10

Jeg tvivler stærkt på at nogen producent vil dele den ene PCIe bane lydkortet er sat til op. Så er vi ude i at der skal bruges en PLX chip som er dyr, det vil ingen mening give og være totalt overkill at lave sådan noget på chipsettet.



alenkaer
 
Enthusiast
Tilføjet:
29-12-2018 23:28:58
Svar/Indlæg:
238/6

Prøvede lige at rykke lidt rundt i computeren. Jeg tænkte den mest sikre måde var, at få så mange lanes fri som overhovedet muligt, for at få begge M.2 port til at køre PCIe 3.0x4, så jeg slog Asmedia USB controller, onboard lyd, SATA controller og netværks fra i bios. Samt tog mit Soundblaster Z lydkort ud.

Endte med mine to diske en 970evo og en 960 Pro køre PCIe 3.0x4 på port 1 og PCIe 3.0x2 på port 2. Så uanset hvor mange lanes fra chipset jeg gør fri, kan jeg ikke få det til at køre x4/x4 på M.2 portene. Begge porte køre fint PCIe 3.0x4, når kun en disk benyttes.

Nogen forslag? Resten af systemet er opdateret i profil, hvis nogen har gode råd :)



Burgurne
 
Nyhedsskribent
Tilføjet:
30-12-2018 00:52:43
Svar/Indlæg:
4319/847

Okay! Det lyder som om det er godt jeg ikke har solgt min ASUS PCIe-adapter til NVMe 😕.

 

 



freak_master
 
Redaktør
Tilføjet:
30-12-2018 07:56:36
Svar/Indlæg:
5803/461

#12

Bruger du SATA port 1 og 2? Hvis den deler det op så du stadig kan bruge SATA porte er det nok derfor. Det er muligt at du skal justere M.2 porten til at køre x4 i BIOS også.

I følge ASUS ser det sådan ud:

1 x M.2 Socket 3, with M key, type 2242/2260/2280 storage devices support (SATA & PCIE 3.0 x 4 mode)*1
1 x M.2 Socket 3, with M key, type 2242/2260/2280/22110 storage devices support (PCIE 3.0 x 4 mode)

Så der burde ikke være andet end SATA porte der tager PCIe baner fra den ene M.2 port. Hvilken port er det der kører kun x2?

 

#13

I har begge ASUS bundkort, men de er begge forskellige. Jeg ville ikke være alt for urolig med at sætte begge SSD'er i M.2 portene på dit, men det kan være at du også skal indstille noget i BIOS for at få det til at fungerer.



alenkaer
 
Enthusiast
Tilføjet:
30-12-2018 10:38:37
Svar/Indlæg:
238/6

Har ingen SATA drev i computeren og SATA controlleren er helt disabled i bios.

Har tested at begge porte kan køre x4, når kun et drev er installeret i computeren. Når begge porte i brug kører port 2 kun x2. Også selvom jeg gør så mange af de 24 lanes fra chipset fri, ved at slå så mange onboard devices fra, så som den extra usb 3.1 controller, LAN og lydkort, samt fjernet mit pcie lydkort.

Syntes det er noget af en fejl, det ikke fremgår hverken på produktsiden eller i manualen, at begge porte ikke kan køre x4 mode, når begge porte er i brug. Det giver jo hellere ikke nogen menning at sætte dem i RAID, når man ender med 2x den langsomste ports hastighed. Med mindre man bruger en PCIe adapter, og vil opgive 8 lanes fra grafikkortet
 



Mapples
 
Elitebruger
Tilføjet:
30-12-2018 12:44:53
Svar/Indlæg:
6097/270

Hmmm, jeg venter stadig på mit drev. Proshop siger de har afsendt det, og de har trukket pengene, men Postnord mener ikke de har modtaget pakken fra Proshop endnu. Det må være et meget langsomt bud der fragter pakken fra proshop til postnords pakkeindlevering ... foreløbig har det varet 2 dage. Jeg vender tilbage når/hvis drevet når hjem til mig.

Skrev Burgurne d. 29-12-2018 13:30:07

Samme problem her.

Tror slet ikke Postnord har hentet pakkerne hos Proshop endnu. 😕



Burgurne
 
Nyhedsskribent
Tilføjet:
30-12-2018 15:06:57
Svar/Indlæg:
4319/847

#16 Ja, det kunne da godt lyde som om du har ret! Jeg afgav min bestilling 27/12 kl 16:45 og der stod da på ProShops side "Bestil inden kl 21, og forventet levering er d. 28/12. Det var den så ikke, da ProShop først meldte den klar til afsendelse d 28/12 😕, og måske pga dette bliver det nu først efter Nytår, at jeg kan prøve hvordan mit mobo kan/vil håndtere 2x NVMe drev. Jeg er lidt spændt på det oven på #15's forklaring, men ser stadgi muligheder da vores bundkort er lidt forskellige som Freak_Master jo ganske rigtigt påpeger.

Forresten, et NVMe drev bruger jo "kun" 4 lanes, men det koster 8 lanes at benytte en PCIe adapter. Nogen der ved om man kan købe en PCIe adapter til 2 NVMe drev, som så kan bruge 8 lanes tilsammen, så der ikke går noget "til spilde"?



Bossmann_dk
 
Superbruger
Tilføjet:
30-12-2018 17:26:12
Svar/Indlæg:
367/22

Har ingen SATA drev i computeren og SATA controlleren er helt disabled i bios.

Har tested at begge porte kan køre x4, når kun et drev er installeret i computeren. Når begge porte i brug kører port 2 kun x2. Også selvom jeg gør så mange af de 24 lanes fra chipset fri, ved at slå så mange onboard devices fra, så som den extra usb 3.1 controller, LAN og lydkort, samt fjernet mit pcie lydkort.

Syntes det er noget af en fejl, det ikke fremgår hverken på produktsiden eller i manualen, at begge porte ikke kan køre x4 mode, når begge porte er i brug. Det giver jo hellere ikke nogen menning at sætte dem i RAID, når man ender med 2x den langsomste ports hastighed. Med mindre man bruger en PCIe adapter, og vil opgive 8 lanes fra grafikkortet
 

Skrev alenkaer d. 30-12-2018 10:38:37

Hm, sad lige og kiggede tråden igennem. Kan det virkelig passe at de nyere cpuer kun har 16 lanes i alt.

fra 8500k til 9900k, var dem jeg lige kiggede på. En 6900k har 40lanes. Hvis der kun er 16, så er det klar at man ikke kan få 2x nvme til at køre x4, mm GFX sættes i x8 ??  . Eller ser jeg helt forkert på det? 

 

Edit: Nå har nu læst lidt på det og chipset lanes spiller også ind. Mit z370 har 24, der ryger 16 til gfx 4 til nvme. skal vist nærlæses lidt mere om det.



Svaret blev redigeret 1 gang, sidst af Bossmann_dk d. 30-12-2018 17:46:26.


Burgurne
 
Nyhedsskribent
Tilføjet:
30-12-2018 22:49:43
Svar/Indlæg:
4319/847

De 16 lanes til grafikkort er de 16 lanes der har direkte forbindelse til grafikkort (deles i 2x8 hvis man kører Sli/Crossfire eller bruger en NVMe adapter i grafikport #2). De 24 lanes er så til "alt det andet", dvs os med de små systemer har ialt 40 lanes at lege med. 

Dem med f.eks Intel X299 der har chipsættet og f.eks en 7800X CPU har mange flere lanes at lege med.



Burgurne
 
Nyhedsskribent
Tilføjet:
03-01-2019 20:26:26
Svar/Indlæg:
4319/847

OPDATERING!

Så er mit 970 EVO drev ankommet, systemet er flyttet, og begge NVMe drev sidder nu i bundkortets 2 NVMe porte. Opdateringen er så som følger:

Samtlige SATA stik (1-6) virker samtidig med de 2 NVMe. Begge NVMe drev kører x4, altså fuld skrald, så jeg får ikke brug for min NVMe PCIe adapter i denne omgang.

Det er tilsyneladende KUN hvis det drev man sætter i den ene NVMe port er et SATA baseret drev, f.eks: https://www.komplett.dk/produc... #  at man vil mangle en eller 2 sataporte.

 



KleitusIV
 
Nyhedsskribent
Tilføjet:
03-01-2019 22:12:55
Svar/Indlæg:
3615/260

#20 Fedt tak for info. Kører dig grafikkort stadig 16x?

 

Det er lige før du skulle kører raid0 på de 2 nvme diske - bare fordi. 😀



Burgurne
 
Nyhedsskribent
Tilføjet:
04-01-2019 02:11:12
Svar/Indlæg:
4319/847

Yep, der er stadig 16 lanes til grafikkortet 🙂.

Jeg kan ikke rigtig gennemskue hvorfor det virker hos mig, og ikke hos alenkaer (#15), jeg ved ikke hvad hans bundkort kan mere end mit som gør, at han har 2 lanes mindre til rådighed for NVMe.

Hehe, raid 0 på NVMe?? Ja, hvorfor ikke. Måske jeg prøver at lave et sæt dynamiske drev på disse 2, og så ser hvad der sker ved det 😎. Det kunne blive et hyggeligt lille weekendjob som snilt kan vare et par bajers tid 😉. Tak for ideen!!!!



freak_master
 
Redaktør
Tilføjet:
04-01-2019 13:43:12
Svar/Indlæg:
5803/461

#18

Din CPU har 16, som har direkte forbindelse til PCIe port 1 og 2 (ihvertfald på de fleste bundkort), og Z370/Z390 chipsettet har 24. De 24 har kontakt med CPU'en igennem DMI 3.0. Det betyder at de 24 PCIe baner som chipsettet har ikke kan bruges på fuld skrald på samme tid, da DMI 3.0 kun har så meget båndbredde. Det betyder tilgengæld at du kan have mange enheder koblet til systemet igennem PCIe på en gang, de må så dele om den fælles båndbredde de kan få til CPU'en.

 

#22

Jeg har 2 Samsung NVMe 256GB i RAID 0, bliv ikke skuffet når du kun ser 3.5GB/s sekventiel læs/skriv, da det er DMI 3.0's cirka maksimum. Jeg fik ikke meget ud af at køre RAID 0, det er mest i 4K som faktisk ikke gav meget mere end hvad de enkelte diske kan.



KleitusIV
 
Nyhedsskribent
Tilføjet:
04-01-2019 15:57:02
Svar/Indlæg:
3615/260

#23 Det lyder da rigtig øv.

 

Sidst jeg kørte Raid0 var med SATA SSD, hvor hver disk lå på ca 550mb/s, som er næsten lig SATA's max hastighed på 600mb/s. Men ved raid0 fik jeg over 1000mb/s - også selvom SATA stadig har max kapacitet på 600mb/s - det var kombinationen af de to. Men med SATA kan de måske køre samtidig og med DMI 3.0 så er kapaciteten den totale for alt på båndet? 

 

Fidusen ved raid0 er jo at den (i teorien) kan køre med 3500mb/s på det ene drev og samtidig køre 3500mb/s på det andet, og begge drev arbejder med samme fil, så den totale hastighed bliver 7000mb/s.

 

Så læser jeg dit resultat som at når man IKKE kører raid0 og bruger begge drev på samme tid, vil de blive halveret fordi den samlede båndbredde ikke kan overstige mere end hvad et enkelt i forvejen kan køre? Eller...?

 



Svaret blev redigeret 1 gang, sidst af KleitusIV d. 04-01-2019 15:59:25.


Burgurne
 
Nyhedsskribent
Tilføjet:
04-01-2019 15:58:02
Svar/Indlæg:
4319/847

Okay, så behøver jeg jo ikke spilde "weekendtid" på at teste RAID 0, freak_master. Hmmmm, så må jeg finde en anden undskyldning for at have et lille let job der passer til et par bajeres tid 😉

 

Forresten ... er det placeringen af mine NVMe drev, eller er det normalt at 960 EVO er ca 10° varmere end 970 EVO mens der testes i f.eks Crystal disk mark? Jeg har i hvert fald en forskel på nævnte 10° ca i.flg HWMonitor. 



KleitusIV
 
Nyhedsskribent
Tilføjet:
04-01-2019 16:00:21
Svar/Indlæg:
3615/260

#25 Er der et af dem der sidder lige ved siden af grafikkortet? Eller lige under CPU køleren? Eller VRM's? Det kan vel være derfor..



alenkaer
 
Enthusiast
Tilføjet:
04-01-2019 19:51:07
Svar/Indlæg:
238/6

Samsungs Polaris controller er en ret varm chip, bla. derfor valgt man at bruge et lag copper i markaten til at fordele varmen over et større område. Det var et stort problem på 950 serien, da diskene ofte begyndte at throttle ved større mængder skrivning til diskene

Min 960 pro sidder idle på 40 grader, hvor min 970 evo kun er 32



Svaret blev redigeret 1 gang, sidst af alenkaer d. 04-01-2019 19:52:52.


Burgurne
 
Nyhedsskribent
Tilføjet:
04-01-2019 20:23:10
Svar/Indlæg:
4319/847

#26 ja, men de sidder begge tæt på andre varmekilder, men #27 har sikkert svaret det rigtige, jeg har nu prøvet at lade den idle i 10 minutter, og der er der også en forskel, så det er sikkert varmefordelingen der er blevet bedre 🙂



freak_master
 
Redaktør
Tilføjet:
04-01-2019 20:52:33
Svar/Indlæg:
5803/461

#24

I tilfældet med SATA, så er hver port god for cirka 550MB/s, hvorfor man fint kan ramme 1GB/s sekventiel hastighed med et RAID 0 med 2 diske. Alle SATA porte er koblet til chipsettet, og chipsettet skal være chippen der fordeler diverse ting på bundkortet og sørger for kommunikationen til CPU'en.

Essentielt skal dataen fra SSD disken(e) til chipsettet via PCIe, for derefter at blive sendt videre til CPU'en igennem DMI 3.0. DMI 3.0 har en båndbredde på cirka 3.5GB/s, hvorfor at man med f.eks. 6 SATA diske i RAID 0 aldrig vil kunne komme over 3.5GB/s.

Det samme gør sig gældende for M.2 NVMe. En NVMe disk på f.eks. 3GB/s kan fint yde sit maksimum, da data skal fra PCIe x4 til chipsettet, og videre fra chipsettet til CPU'en via DMI 3.0.

Hvis vi så sætter to NVMe diske i RAID 0, så kan disse sikkert fint ramme 6GB/s sammen, men her har vi den meget omtalte flaskehals, hvor DMI 3.0 ikke kan nå at sende alt data videre, hvorfor vi ser en maksimum sekventiel hastighed på 3.5GB/s.

Hvis du kigger på Intel's chipset block diagram, så kan du også se dette. Jeg medtager det altid i vores bundkort artikler: https://hwt.dk/test/60817/giga...

Her kan du se at RAM har direkte forbindelse til CPU'en, og det samme med i alt 16 PCIe 3.0 baner der kan deles op på 3 forskellige måder. Resten har forbindelse til chipsettet, hvor forbindelsen mellem chipsettet og CPU'en består af DMI 3.0.

Det betyder også at du heller ikke kan kopiere fra den ene NVMe SSD til den anden med fuld skrald, da det hele lige skal forbi CPU'en. Prøv at skriv til 10 USB keys på samme tid, især hvis det er nogle hurtige USB 3.0 kommer du hurtigt til at se at efterhånden som du sætter nye USB diske til at kopiere ting på, så vil alle de andre USB hastigheder falde. Der er bare ikke mere at give af.

 

Hvis du vælge X299 og en CPU med mange flere PCIe baner behøver du ikke have denne flaskehals, da du nemt kan smide et stort grafikkort i (eller to) samtidig med at have 2 NVMe diske sat direkte til CPU'en.



KleitusIV
 
Nyhedsskribent
Tilføjet:
04-01-2019 21:04:13
Svar/Indlæg:
3615/260

#29 Tak for en super forklaring - du er mesteren. 🙂

 

Men det betyder jo så også at når Burgurne har 2x nvme diske i, så kan det godt være de begge kører x4 og begge kan levere 3500mb/s, men kører de SAMTIDIG, vil de skulle vente på hinanden eller gå ned på halv hastighed, fordi de skal deles om en flaskehals på max 3500mb/s.



Burgurne
 
Nyhedsskribent
Tilføjet:
04-01-2019 21:08:13
Svar/Indlæg:
4319/847

#30, ja, sådan forstår jeg det også, men til gengæld er loadtider fra ENTEN den ene ELLER den anden altid på diskens max. Anyway, de kan jo ikke kopiere hurtigere til hinanden end skrivehastigheden på den disk der kopieres til 😉, og da ingen af min er PRO udgaven, er der jo her en form for flaskehals alligevel.

Med ja, se da at få PCIe 4.0 på vores bundkort / NVMe drev!!



Burgurne
 
Nyhedsskribent
Tilføjet:
05-01-2019 23:10:59
Svar/Indlæg:
4319/847

Okay, træerne vokser ikke ind i himlen (så er de også fandens besværlige at beskære!). Fra i morges kunne min PC ikke vågne fra sleep eller hibernate mere. Der kom denne fejl:

0xa0_608_STACKPTR_ERROR_secnvme!NVMePoCheckF0State 

BlueScreen 
Ikke tilgængelig 
1c74de02-48f3-455f-92cf-721983b27222 
a0 
608 
ffffa981303e01f8 


10_0_17763 
0_0 
256_1 
\\?\C:\Windows\Minidump\010519-11265-01.dmp \\?\C:\Windows\TEMP\WER-14046-0.sysdata.xml \\?\C:\Windows\MEMORY.DMP \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER40D1.tmp.WERInternalMetadata.xml \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER40E2.tmp.xml \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER40F1.tmp.csv \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER4111.tmp.txt 
\\?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\Kernel_a0_15899aced7b3dddc1a29ca089c9a36e91e9 74ef_00000000_cab_10a09bc3 

ff934cad-a827-4e5a-9dea-ca8a77505548 
268435456 

 

I tenforums.com blev jeg så anbefalet at afinstallere Samsung NVMe driveren, og så bare benytte Windows egen NVMe driver, så det prøvede jeg, og jo ... fejlen forsvandt, så nu virker PC'en fint igen, men der er et lille performancetab i.flg. Crystal Disk Mark. Værste tilfælde er dog på 5%, så det er ikke noget jeg vil mærke, men det irriterer alligevel lidt. Samt, hvorfor kan Samsungs driver til Samsungs drev ikke fungere, bare fordi der nu er 2 NVMe drev? Det fungerede jo fint et par dage, men jeg er åbenbart ikke den eneste der har oplevet dette. Well, måske Samsung en dag vil udgive en ny driver der kan tage sig af mere end et NVMe drev i mere end et par dage 😀




www.bildelestore.dk