Fejl på ram - forstå memtest86

Ram d.  23. januar. 2019, skrevet af mangekyo
Vist: 232 gange.

mangekyo
 
Superbruger
Tilføjet:
23-01-2019 09:02:30
Svar/Indlæg:
499/11

Efter jeg har samlet computer med lidt nyere dele, så begyndte jeg at opleve nogle BSOD. Her begyndte jeg lidt at mistænke rammene for at have fejl, så har lige kørt en Memtest86, og den fandt fejl i en af testene.


Jeg vil ikke vide noget om fejlene, men jeg vil gerne prøve at forstå meningen med beskeden som programmet melder.

Skal man forstå det sådan, at det er CPU'en som forventer en bestemt adresse fra rammene, men altså får en anden og derfor sker der en fejl?



Tråden blev redigeret 3 gange, sidst af mangekyo d. 23-01-2019 09:03:24.
minoo
 
Superbruger
Tilføjet:
23-01-2019 11:24:51
Svar/Indlæg:
193/26

Åhh Jeg ved ikke så meget om det men, memtest har jo forventet at linje 1 gør BFFFFEFF, men har gjord FFFFFEFF, hvilket gør at den laver fejl. 



freak_master
 
Redaktør
Tilføjet:
23-01-2019 11:40:32
Svar/Indlæg:
5844/462

Adressen er den fysiske adresse i dine RAM, det referer til et bestemt sted i en bestemt chip i dine RAM, hvor fejlen forekommer.

Memtest forventer at få et resultat tilbage, hvordan helt præcist ved jeg ikke, men den får ikke det resultat som det, hvorfor der bliver logget en fejl.

Prøv at hæv VCCIO til 1.1 volt, og RAM volt til 1.4 og se om du stadig får fejl. Det er meget muligt at IMC'en ikke kan følge helt med, det er ihvertfald det typiske scenarie.



mangekyo
 
Superbruger
Tilføjet:
23-01-2019 12:59:05
Svar/Indlæg:
499/11

#2 Jeg har prøvet det du foreslog. VCCIO var allerede sat til 1.2 volt og RAM hævede jeg så til de 1.4. Det gjorde at fejl blev mindsket ned til 26 per pass. Men stadig fejl.

Vil yderligere volt muligvis kunne afhjælpe? Jeg er lidt usikker på hvor meget volt jeg tør give dem.



freak_master
 
Redaktør
Tilføjet:
23-01-2019 13:02:16
Svar/Indlæg:
5844/462

Ehh jeg håber da ikke for dig at du kører 1.2 volt VCCIO, jeg vil aldrig gå højere end 1.15, over det vil du begynde at de degration i løbet af nogle måneder.

Hvis du har kørt 1.2 volt VCCIO siden maskinen blev bygget, så kan det godt være at fejlen er kommet på grund af degration af CPU'ens IMC.

Har du manuelt sat den til 1.2, eller læser BIOS det som 1.2?



mangekyo
 
Superbruger
Tilføjet:
23-01-2019 13:03:30
Svar/Indlæg:
499/11

#4 Det er BIOS der selv læser det sådan. 



freak_master
 
Redaktør
Tilføjet:
23-01-2019 13:10:10
Svar/Indlæg:
5844/462

#5

Så læser den helt sikkert ikke korrekt. Sæt den til 1.1 manuelt, så skal den nok sætte sig til 1.1, og den vil sikkert også læse 1.1.

Det er ikke unormalt at BIOS læser helt ved siden af når den står til auto.



mangekyo
 
Superbruger
Tilføjet:
23-01-2019 13:10:43
Svar/Indlæg:
499/11

Hvis jeg sætter VCCIO lavere end det AUTO kører med, altså BIOS der siger 1.2 så får jeg endnu flere fejl end før.

 

Edit:
#5 Prøvede det med 1.1 - det gav ovenstående.



Svaret blev redigeret 1 gang, sidst af mangekyo d. 23-01-2019 13:11:22.


freak_master
 
Redaktør
Tilføjet:
23-01-2019 13:15:36
Svar/Indlæg:
5844/462

Så ved du jo faktisk hvad der er galt. Din CPU har kørt med for høj VCCIO og din IMC er degraderet og kan ikke længere køre med 3200MHz RAM. Sæt RAM ned i hastighed og VCCIO til 1.1 og se hvor du kan blive stabil, og håb på at den ikke degraderer sig mere, eller skift CPU 😕



mangekyo
 
Superbruger
Tilføjet:
23-01-2019 13:19:35
Svar/Indlæg:
499/11

#8 Jeg prøver mig lidt frem og ser hvad jeg kan få ud af det.

Er det bundkortets skyld at VCCIO er sat sådan? Det virker da lidt underligt hvis det ikke er afstemt helt.



freak_master
 
Redaktør
Tilføjet:
23-01-2019 13:35:48
Svar/Indlæg:
5844/462

Standard VCCIO er 0.95 volt, men det hænder at nogle bundkort, når XMP bliver sat til, sætter en alt for høj VCCIO, det var især på Skylake at det var et problem, og jeg troede ærligt at producenterne var stoppet.

Selvfølgelig sætter producenterne en høj VCCIO, så kan selv den værste IMC være med på 3200MHz, problemet kommer så bare et par måneder efter 😕

Det er desværre ikke det eneste sted at producenter sætter for høj volt, VCCSA kan også blive sat til 1.2 har jeg set, hvor standard også er 0.95.

Det er virkelig ikke nemt at gøre sig klog på, og jeg tror man virkelig skal være dedikeret før man finder ud af disse ting, de fleste aktiverer jo bare XMP og kører med det.



mangekyo
 
Superbruger
Tilføjet:
23-01-2019 13:55:59
Svar/Indlæg:
499/11

Ja det har jeg da bare gjort, for ja, når man ikke ved bedre. Men det er da tydeligt at ASRock ikke har ændret på det...

Ser ud til at jeg kan køre 3000 MHz på ram stadig med 1.1 VCCIO. Så skal jeg bare lige have set resten af volt igennem for at se om den også har lavet problemer andre steder.



freak_master
 
Redaktør
Tilføjet:
23-01-2019 16:18:03
Svar/Indlæg:
5844/462

Nu ved du hvad du skal gøre hvis den bliver træls igen ihvertfald 🙂

 

Held og lykke 😉




www.bildelestore.dk