adapter til M.2 porte

Bundkort & CPU d.  16. november. 2019, skrevet af martinta
Vist: 613 gange.

martinta
 
Senior Skribent
Tilføjet:
16-11-2019 13:07:53
Svar/Indlæg:
2798/99

Hej

Er der nogle herinde der har erfaringer med at smide et kort i PCI-e portene så der kan sættes M.2 SSD'er i? :)

maskinen er en ældre dame, og udskiftning af maskinen er ikke noget som ligger i kortene grundet dens andre specs (og pris for en ny). Men er løbet tør for Sata porte, så må jo være kreativ :) 

Walenad
 
Elitebruger
Tilføjet:
16-11-2019 13:43:07
Svar/Indlæg:
1647/23


bender!!!
 
Elitebruger
Tilføjet:
16-11-2019 14:30:12
Svar/Indlæg:
2233/148

bare husk du nok ikke kan Boote med den Adapter med M2, uden at finde en BIOS hack til det, men som nr 2 harddisk kan du uden problemer 

 



Svaret blev redigeret 1 gang, sidst af bender!!! d. 16-11-2019 14:30:40.


animal-mik
 
Elitebruger
Tilføjet:
16-11-2019 15:02:03
Svar/Indlæg:
882/156
hvis bare flere porte - hvorfor ikke et billigt SATA PCI-E kort til 4 porte - så får du da flere SAta porte "billigt" - ? evt et raid kort.


Burgurne
 
Nyhedsskribent
Tilføjet:
16-11-2019 16:30:58
Svar/Indlæg:
5114/1127

#0 Jeg har haft brugt en ASUS adapter til dette, og den kunne jeg godt boote fra på mit gamle bundkort.


 

Den virker fint sammen med en Samsung 960 EVO 512Gbyte 🙂



bender!!!
 
Elitebruger
Tilføjet:
16-11-2019 18:19:42
Svar/Indlæg:
2233/148

#4 okay mit kan ikke uden at jeg bruger en hack Bios 🙂 



Burgurne
 
Nyhedsskribent
Tilføjet:
16-11-2019 20:34:07
Svar/Indlæg:
5114/1127

Ved ikke om ASUS havde hacket sin egen bios, men det er jo en ASUS adapter og bundkortet var et ASUS 😉

Måske det kan have noget at sige??



martinta
 
Senior Skribent
Tilføjet:
16-11-2019 21:52:57
Svar/Indlæg:
2798/99

Gågle er din ven

https://www.google.com/search?...

Skrev Walenad d. 16-11-2019 13:43:07

Nu beder jeg ikke om et kort men om erfaringer med kortet, at google en adapter kan de fleste nok finde ud af. Jeg har haft et kort jeg smed i maskinen som IKKE virkede, derfor jeg beder om erfaringer for ikke at spilde flere penge. Dog får du ros for i det mindste ikke at smide et LMGTFY link 😉 

Jeg behøver ikke kunne boote fra det, jeg forsøgte i første omgang med denne.

https://www.proshop.dk/Harddis...

Men den kunne hverken ses i BIOS eller i Windows. Havde en forventning om at bare den havde en ledig port, så burde det virke. 

Jer der kører med det, hvilket OS kører i med? og kan i set den i BIOS eller først når i kommer ind i Windows? Tænker siden i ikke kan boote fra den 🙂 



martinta
 
Senior Skribent
Tilføjet:
16-11-2019 21:59:33
Svar/Indlæg:
2798/99

hvis bare flere porte - hvorfor ikke et billigt SATA PCI-E kort til 4 porte - så får du da flere SAta porte "billigt" - ? evt et raid kort. 
Skrev animal-mik d. 16-11-2019 15:02:03

Joh :) Men har jo hverken fysisk plads, eller flere ledige strømstik, det er derfor M.2 giver god mening.



Burgurne
 
Nyhedsskribent
Tilføjet:
16-11-2019 22:03:50
Svar/Indlæg:
5114/1127

Altså jeg kunne godt se min i både BIOS og i Windows. Den du linker til er en større version end den jeg har, da min adapter kun har en port. Da du ikke skal kunne boote fra den er det oplagte spm om, hvordan man vælger HVILKET NVMe drev man skal boote fra, jo ligegyldigt 😀

Jeg kørte med Windows 10 da jeg købte adapteren

 

 



martinta
 
Senior Skribent
Tilføjet:
16-11-2019 22:08:05
Svar/Indlæg:
2798/99

Hvis vi skal have hele historien med, så er det en maskine jeg bruger som server til test.

Dvs. den er pt. installeret med en server 2019. 

serveren er med 10 kerner, og deraf 20 tråde. Derudover har den 96 Gb ram. Så at skifte den ud "bare" fordi den mangler flere diske ville være lidt spild af en ellers fin maskine.

Maskinen bruges til at teste forskellige løsninger inden de implementeres ved kunder. Derfor kan der godt være 20-30 "servere" i forskellige miljøer af gangen, hvoraf miljøerne blot er slukkede når de ikke bruges. Så de tager plads men ikke ram. 

Alternativet er naturligvis at købe større SATA SSD'er, men det vil jeg egentlig helst undgå. De nuværende fejler jo ikke noget. så jeg vil hellere udvide med flere. 

Det skal lige siges at jeg da jeg købte den anden adapter smed en ny disk i, og koblede de andre fra, og prøvede at smide win10 på, men heller ikke der hjalp det noget.

Maskinen er en HP Z620 med en E5-2680, så om det er dér jeg oplever en begræsning på CPU generation aner jeg ikke. Derfor jeg søger erfaringer fra jer andre.



martinta
 
Senior Skribent
Tilføjet:
16-11-2019 22:09:30
Svar/Indlæg:
2798/99

#9

Kan du se selve disken i BIOS? Der er jo naturligvis også muligheden for at den enhed jeg har fået var DOA. 



Burgurne
 
Nyhedsskribent
Tilføjet:
16-11-2019 22:21:45
Svar/Indlæg:
5114/1127

Ja, den kunne  ses i BIOS på mit daværende ASUS mobo, nok også derfor windows kunne installeres og bootes fra den. 

Jeg må tilstå, at jeg ikke har prøvet den i mit nuværende AsRock Z390 mobo, da der her er 3 porte på selve mobo'et. Jeg har haft den smidt i mit sidste mobo, ASUS Z370 Gaming-h, for at se om den kørte bedre der da jeg købte min nr 2 NVMe disk. Da jeg havde en at boote fra der, prøvede jeg ikke om den kunne ses i BIOS der, men som data disk fungerede den, dog kørte den lidt langsommere end i porten direkte på bundkortet, så adapteren røg ud igen, og ligger nu bare i skuffen og keder sig 😉



Die_Happy
 
Elitebruger
Tilføjet:
17-11-2019 14:13:34
Svar/Indlæg:
3385/80

Alternativ 1: Køb SSD og adapter/controller, og spild en masse tid på (måske) at få det til at virke.

Alternativ 2: Køb en ny og større SSD og sælg den/de gamle og vær kørende på meget kort tid.

 

Jeg ved godt hvad jeg havde valgt :)



martinta
 
Senior Skribent
Tilføjet:
17-11-2019 15:08:28
Svar/Indlæg:
2798/99

#13

Du er også altid så positiv :) 

Men du har jo i princippet ret, et alternativ er naturligvis at købe større diske og så kassere de gamle. Er dog stadig mere ivrig efter en løsning med en M.2 adapter. 



Walenad
 
Elitebruger
Tilføjet:
17-11-2019 16:29:28
Svar/Indlæg:
1647/23

Hvilke kort er det du har prøvet? Der er vel ikke en eller anden bios-setting som skal enables for at understøtte andre kort?

 

Fra Generation 6 Intel  chip-set burde det altså virke som lager (dog ikke boot uden hack etc)



#16
AXE
 
Elitebruger
Tilføjet:
17-11-2019 22:40:11
Svar/Indlæg:
1088/36

Kører selv med det asus mini cart til M.2 med en Samsung 950Pro 512Gb M.2 SSD Nvme drev som D drev. mens styresystemet kører på den onboard M.2 stik med en Samsung EVO 970 Plus 500Gb Nvme. som C Drev.

Og det spiller fint sammen kopi fra den ene til den anden ligger fast på 2000mb/s.

Benchmark af de 2 diske er ens hvor enten de sidder det ene eller det andet sted. eks EVO 3500mb/s read på bundkortet eller i den adapter. det er samme resultat.



Svaret blev redigeret 1 gang, sidst af AXE d. 17-11-2019 22:42:42.


martinta
 
Senior Skribent
Tilføjet:
17-11-2019 23:20:30
Svar/Indlæg:
2798/99

#15

Hmm, kan være der er noget der, CPU'en er en E5-2680V2, så den er fra 2013. 

Den jeg har prøvet med er denne: 

https://www.proshop.dk/Harddis...

Jeg var optimistisk nok til at tænke, at hvis den bare overholdt grænsefladen, så burde det virke (altså, at den havde en ledig PCI-e 3.0 x16.). Men der tager jeg måske fejl?



tf-uno
 
Elitebruger
Tilføjet:
18-11-2019 08:20:05
Svar/Indlæg:
317/39

Vil sige jeg har været ude i noget af det samme. :)

Købte også en adapter, smed den i min Vmware som køre på en Dell T330- alt spillede lige ud af posen.

Lagde om til Hyper-v på et 2019 miljø, pludselig kunne den ikke se disken. Hmm prøvede at installere win 2016 i stedet, ingen forskel. Der var ingen udråbstegn i enhedshåndtering. Mærkeligt.

Ud med kortet også i min stationær som køre win 10, kunne heller ikke se disken, først efter en genstart.

Tilbage i serveren, ingen disk. Ind i Bios ingen disk, gemte bios opsætning - wupti disken kom. :)

Efter et halv år opdaterede jeg biosesn også forsvandt den igen. ind i biosen og gemme opsætningen også var den tilbage.

Hvorfor det er nødvendig på min dell server kan jeg ikke sige, men det virkede :)

 

 



Walenad
 
Elitebruger
Tilføjet:
18-11-2019 18:00:33
Svar/Indlæg:
1647/23

#17 - kan også bare være, at HP kræver du benytter noget bestemt godkendt hardware. Jeg er sikker på, at hvis du tog en original HP raid-controller, så ville den virke.