Betydelig benchmark forskel mellem safemode og "rigtig" windows - hvor er fejlen?

HDD/SSD d.  13. juni. 2020, skrevet af Burgurne
Vist: 603 gange.

Burgurne
 
Nyhedsskribent
Tilføjet:
13-06-2020 11:26:23
Svar/Indlæg:
5114/1127

Hej.

Som beskrevet i min profil har jeg 2 stk NVMe drev, 960 EVO 500Gb samt 970 EVO (ikke PLUS) 500Gb.

Jeg har gennem et stykke tid følt, at de ikke kørte optimalt, men selv  en clean installering af Windows har ikke hjulpet. Her er mine resultater for 970 EVO, først alm. windows boot, og nedenunder Windows i Safemode:



Som det ses, så er 4K Q32T1 og 4K næsten dobbelt så høje i safemode som i alm. boot. Jeg har hele tiden ment, at det MÅSKE er fordi det er mit boot drev. 

Så nu har jeg også testet mit "data"-drev, 960EVO. Igen, først alm boot, og derefter samme drev i Safemode:



 

Igen en betragtelig forskel i 4k modes.

Nogen der kan komme med en god forklaring, eller en ide til, hvor jeg skal søge efter det ydelsestab?

lp_larsen
 
Elitebruger
Tilføjet:
13-06-2020 12:26:16
Svar/Indlæg:
313/62

Jeg er ude i rent gætværk, MEN... 

Så vidt jeg husker, er "safe mode" uden drivere indlæst. 

Måske du har en driver et sted i dit system der trænger til opgradering? 



Rasmus66
 
Elitebruger
Tilføjet:
13-06-2020 14:26:43
Svar/Indlæg:
8762/174

Af hvad jeg lige har kunne finde af lidt information så var der nogen der snakkede om at en af grundene til det kunne være Spectre og meltdown patches.

https://forums.tomshardware.co...

Det er da værd at prøve og teste lidt videre med, hvis det er en Intel platform du bruger.



Burgurne
 
Nyhedsskribent
Tilføjet:
13-06-2020 15:11:33
Svar/Indlæg:
5114/1127

Godt forslag #2, men det er ikke der fejlen er:


 

Som det ses her, så er både meltdown og spectre protection disabled, og tallene ligner ret meget det fra tidligere.

 

#1 Nyinstalleret windows, så hvilke drivere skulle det være? Seq Q32T1 read/write er jo også det samme i safemode og i alm. mode. Det er først når det kommer til 4K "afdelingen" at det går galt.



yupper
 
Elitebruger
Tilføjet:
13-06-2020 15:28:27
Svar/Indlæg:
1311/10

Du kan jo evt. tjekke de drivere som der bruges under "normal" brug og i safemode, her mener jeg navn og versionsnumre. 

når du laver en clean installation, så forstår jeg det som at du ikke installere antivirus eller andet software der kan påvirke dine diske, heraf mit forslag.



Burgurne
 
Nyhedsskribent
Tilføjet:
13-06-2020 15:34:32
Svar/Indlæg:
5114/1127

Det er ret uoverkommeligt at tjekke alle drivere til alle dele på bundkort osv, men jeg har tjekket drivere til selve NVMe-drevene, og det er samme drivere (windows egne). Jeg har også prøvet Samsungs drivere, men det gav ingen forskel.



KleitusIV
 
Redaktør
Tilføjet:
14-06-2020 19:47:48
Svar/Indlæg:
4079/294

Rent gæt, men kan det ikke også være nogle windows services der kører i normal tilstand, men som ikke kører i safemode? Noget indexing, search, antivirus eller andet. Der kører jo et hav af windows-ting selv efter frisk installation og de kan jo bruge disk-performance.



Burgurne
 
Nyhedsskribent
Tilføjet:
14-06-2020 21:31:29
Svar/Indlæg:
5114/1127

I.flg. Jobliste, så er diskforbruget 0% lige inden test, 100% mens jeg tester og 0% igen efter test. Og igen, det er kun i 4K tests at der er denne ca halvering af performancen. I ren seq read/write er hastigheden den samme i Safemode og i alm boot.

Men ja, det kan sagtens være en service, men hvordan finder jeg ud af hvilken det er??



yupper
 
Elitebruger
Tilføjet:
16-06-2020 10:36:30
Svar/Indlæg:
1311/10

nu kan jeg se at du bruger version 5.2.0 og den nyeste version hedder 7.0.0 hvad med at prøve med den.



freak_master
 
Redaktør
Tilføjet:
16-06-2020 11:14:49
Svar/Indlæg:
6183/473

Hvordan kører det i forhold til andre? Er der nogen der måske kan melde ud hvad de får i "normal" windows med denne SSD? Jeg har den desværre ikke.

Men jeg kan forestille mig at du ikke er den eneste med problemet. Fordi disken står til 0% betyder ikke at den slet ikke bruges. Når du ikke kører i fejlsikret tilstand har Windows en enorm mængde services der kører i baggrunden, disse services skal hele tiden læse eller skrive en lille smule til disken, som kan give dette udslag. Jeg er enig i at forskellen er enorm, men jeg tænker stadig at den måske kan være normal, hvis andre med denne disk ville køre en hurtig test.

Dertil kommer også pagefile, hvis du bruger den, bruger du jo din disk som RAM, hvis du har mange ting åbne når du kører "normal" windows, vil disse ikke starte i fejlsikret tilstand, ligesom services, og du vil måske ikke hoppe over og bruge din pagefil men have det hele i RAM.



Burgurne
 
Nyhedsskribent
Tilføjet:
16-06-2020 17:05:51
Svar/Indlæg:
5114/1127

#8 Det er kun for sammenligningens skyld, det ændrer intet at skifte til højere versionsnummer, men så kan jeg ikke direkte sammenligne ældre resultater. Derfor ver 5.2.0.

 

#9 Jeg har 32 Gbyte ram, og alle tests er foretaget på et nybootet PC, med kun det nødvendigste som autostart (BitDefender, Logitechs LGhub osv), så den burde absolut ikke bruge pagefile på dette tidspunkt.

Din ide med at få andre til at teste på tilsvarende vis er genial. 🙂 Så alle her med et NVMe drev, har I også en så stor forskel mellem alm boot og boot til safemode? 



Gripen90
 
Senior Skribent
Tilføjet:
17-06-2020 23:20:34
Svar/Indlæg:
15841/629

Desværre ikke nogen løsning, men jeg kan se andre har oplevet det samme https://answers.microsoft.com/...

Jeg prøver, at køre et par tests i normal og safe mode når jeg har lejlighed på min Crucial p1 NVMe.



Burgurne
 
Nyhedsskribent
Tilføjet:
17-06-2020 23:28:04
Svar/Indlæg:
5114/1127

#11 Ja, det ser ud til, at han/hun har samme problem, igen mest med 4k tests. Ser frem til din test, så det kan afgøres om det er her, en indstilling eller windows der har et problem.



Cocio21
 
Moderator
Tilføjet:
18-06-2020 07:21:09
Svar/Indlæg:
4871/46

Jeg tænker det handler om NVME ikke rigtigt har en safemode controller driver...

Og alm Sata bliver jo vistnok stadig sat i PIO selv i Win10 ?

Men hvis NVME ikke begrænses i safemode via driveren, så kan det lidt lavere input forbrug vel godt give et bedre resultat for NVME input latency krævende tasks :)



Burgurne
 
Nyhedsskribent
Tilføjet:
18-06-2020 09:45:03
Svar/Indlæg:
5114/1127

Jo, men NVMe kan jo kun kommunikere med resten af PC'en vha en driver? 

Hvis det skulle være noget baggrundshalløj (kan det sagtens være!!), hvorfor påvirker det så aldrig seq read/write, men altid kun 4k-testene? Man skulle jo tro, at baggrunds"halløj'et" ville være der uanset om det er den ene eller anden test af NVMe der udføres?



freak_master
 
Redaktør
Tilføjet:
18-06-2020 10:24:15
Svar/Indlæg:
6183/473

Sekventiel operationer er noget nemmere for en SSD end mindre filer. I min verden er det ikke usædvanligt. Controlleren i SSD'en er den der kommer på arbejde når det er små filer, men det er selve flash chips der kommer på arbejde med store filer.



Burgurne
 
Nyhedsskribent
Tilføjet:
18-06-2020 17:31:01
Svar/Indlæg:
5114/1127

Ja, det er korrekt #15, men mon controlleren i SSD'en ved om windows er bootet normalt eller i safemode?? 😉



Gripen90
 
Senior Skribent
Tilføjet:
18-06-2020 18:04:12
Svar/Indlæg:
15841/629

Jeg har lige prøvet i normal Windows og i safe mode,  og forskellen var marginal på mine Ryzen setups og Crucial P1 500GB/1TB NVMe. Jeg forsøgte på min 3950X med Asus ROG Strix X570-F Gaming og Crucial P1 500GB NVMe SSD,  derefter min Ryzen 3900X med Asus Prime X570 Pro og Crucial P1 500GB NVMe SSD og slutteligt med min Ryzen 3600 og Gigabyte X570 I Auros Pro WiFi og Crucial P1 1TB NVMe SSD. Alle 3 systemer med Windows 10 Pro build 1909.

Jeg spekulerer i om det har noget at gøre med Spectre patches i Windows at gøre? Jvf denne tråd https://www.pcworld.com/articl...



Burgurne
 
Nyhedsskribent
Tilføjet:
18-06-2020 21:57:02
Svar/Indlæg:
5114/1127

#17 Se #3. Har prøvet det med Spectre og Meltdown. Du har vel ikke et Intel setup? Det kunne jo rent faktisk være et Intel-problem?



Gripen90
 
Senior Skribent
Tilføjet:
19-06-2020 18:27:45
Svar/Indlæg:
15841/629

 

Burgurne skrev d. 18-06-2020 21:57:02

#17 Se #3. Har prøvet det med Spectre og Meltdown. Du har vel ikke et Intel setup? Det kunne jo rent faktisk være et Intel-problem?

Jeg har desværre ikke NVMe drev i mine to Intel systemer (i7 5960X og i7 6950X) blot SSD'er, men jeg kan bekræfte at Spectre og Meltdown patches og updates har påvirket ydelsen negativt på CPU siden. Jeg har blot almindelige 2'5 Sata3 SSD'er i de to pc'er, men kan godt prøve at teste i normal Windows og safe mode.



Burgurne
 
Nyhedsskribent
Tilføjet:
19-06-2020 22:28:32
Svar/Indlæg:
5114/1127

Ja tak Gripen, det må du godt. jeg har dog ikke selv flere SATA3 SSD'ere, så jeg ved ikke om jeg har denne fejl på en SATA controller også, eller om det kun er NVMe drev. Da jeg har 2 NVMe drev, og fejlen er på både det der kører direkte gennem CPU'en og det der kører gennem chipsættet, så findes fejlen måske også på SATA3?



Bossmann_dk
 
Superbruger
Tilføjet:
20-06-2020 14:37:58
Svar/Indlæg:
414/24

Hej.

Her er lidt sammenligning med min maskine.

8700K non OC

msi Z370m mortar

32 gb 3200 mhz

1 x WD750 1tb

1 x Mushkin Pilot 1 tb

Wd750 win mode


Wd750 safemode


Mushkin Pilot Win mode


Mushkin pilot safe mode


 

 



Svaret blev redigeret 1 gang, sidst af Bossmann_dk d. 20-06-2020 14:40:11.


Burgurne
 
Nyhedsskribent
Tilføjet:
20-06-2020 17:23:38
Svar/Indlæg:
5114/1127

Mange tak #21. Jeg har gentaget testen på min PC med samme version af CDM, og med alle 4K-tests sat til T8 som du også har gjort. Din bootdisk taber omkring 25% i Write, samt lidt i Read i 4K. Samme test med mit bootdrev (Samsung 970 EVO 512Gbyte)

Alm boot


 

Safemode


 

Jeg taber omkring 50% i Write og ca 33% i Read 😥 MEN HVORFOR?????



KleitusIV
 
Redaktør
Tilføjet:
20-06-2020 22:40:17
Svar/Indlæg:
4079/294

Virkeligt interessant fund! Jeg ved desværre ikke hvorfor, men vil meget gerne vide hvad det kan være. 🙂



Burgurne
 
Nyhedsskribent
Tilføjet:
20-06-2020 22:51:27
Svar/Indlæg:
5114/1127

Jeg har nu prøvet noget lidt drastisk. Har afinstalleret mit BitDefender Internet Security helt, genstartet maskinen så den selv aktiverer Windows egen sikkerhed. Det gav INGEN forskel. Jeg har så prøvet at stoppe tjenesten "Windows search", stadig ingen forskel. Sat Onedrive på pause, stadig ingen forskel.

Jeg har til gengæld nu fået en anden fejl. Tjenesten "Intel(R) Integrated Clock Controller Service - Intel(R) ICCS" har status som "Starter", dvs den kører ikke, men kan heller ikke stoppes. Mon ikke jeg snart læner mig op af en nyinstallering af Windows 10 Pro??

 

Hvad andet kan der tænkes at være, som vil blande sig i en disk-test i 4k-tests?



Sven
 
Superbruger
Tilføjet:
21-06-2020 22:17:55
Svar/Indlæg:
3601/81

preov at fjerne telemetry backgrunds task


schtasks /change /disable /tn "\Microsoft\Windows\Application Experience\AitAgent"
schtasks /change /disable /tn "\Microsoft\Windows\Application Experience\Microsoft Compatibility Appraiser"
schtasks /change /disable /tn "\Microsoft\Windows\Application Experience\ProgramDataUpdater"
schtasks /change /disable /tn "\Microsoft\Windows\Autochk\Proxy"
schtasks /change /disable /tn "\Microsoft\Windows\Customer Experience Improvement Program\Consolidator"
schtasks /change /disable /tn "\Microsoft\Windows\Customer Experience Improvement Program\KernelCeipTask"
schtasks /change /disable /tn "\Microsoft\Windows\Customer Experience Improvement Program\UsbCeip"
schtasks /change /disable /tn "\Microsoft\Windows\DiskDiagnostic\Microsoft-Windows-DiskDiagnosticDataCollector"
schtasks /change /disable /tn "\Microsoft\Windows\Windows Error Reporting\QueueReporting"

Stroemstyring i windows kan have en stor effekt paa I/o benchmarks pga cpu'load er lavt/ under mere cpu kraevede orepation vil i/o stiger

Proev at saet den til high performance.

prove et disable core parking

HDtune var deb ebeste bencmhark jeg kunne finde forskeleli da jeg taste balanced imod high perfomarnce mode i over 20+ bechmarks paa 7 forskellige maskiner

Jeg lave dog samem test med noget cpu kravende i idle priority og bum saa ar hd tune opppe og fint i igen.

 

Hvis ud ikke ved hvordan du disable core parking kan du altid bruge project mercury. den goper det automatisk saa laenge den er koerende ibaggrunden ( ingen permant aendring af dit system

 



 



Burgurne
 
Nyhedsskribent
Tilføjet:
21-06-2020 22:45:56
Svar/Indlæg:
5114/1127

Nu har jeg prøvet at disable alt det du foreslår, 2 af dem melder "error" (se billedet), Strømstyring sat til "høj ydeevne" og Project Mercury kører. 

Det giver, som det ses, ingen forskel.


 

BTW, hvordan får jeg slået alt det til igen, som nu er koblet fra i CMD???



Svaret blev redigeret 1 gang, sidst af Burgurne d. 21-06-2020 22:47:00.